Cómo hacer una factura en Excel paso a paso

Cómo hacer una factura en Excel paso a paso

Aprende a cómo hacer una factura en Excel paso a paso, al final de la entrada podrás descargar el formato de factura que usamos para describir cada uno de los pasos.

Para este ejemplo usaremos el siguiente modelo de factura, el cual nos servirá de ejemplo para el diseño en Excel.

hacer una factura en Excel

Antes de hacer la factura en Excel, primero comenzamos creando 4 hojas las cuales tendrán los siguientes nombres: Factura, Vendedores, Clientes y Productos.

DISEÑANDO LA FACTURA

Para la hoja Factura

En la hoja Factura es donde crearemos el diseño de la factura, comenzamos a diseñar la factura tal como se ve en la imagen anterior, pero excluyendo los datos que se ingresaron en los campos en blanco, para ello sigue los siguientes pasos:

  • Comienza por escribir primero el texto que está en el formato factura (en los campos de color verde), por ejemplo en la imagen se ve CÓDIGO DE VENDEDOR el cual debes escribir en la celda C5.
  • Escribe el texto correspondiente para cada celda con fondo verde, tal como se ve en la imagen.

Una vez hayas terminado de ingresar el texto, el siguiente paso es por bordes, para ello sigue los siguientes pasos:

  • Selecciona las celdas, ir a la pestaña Inicio, en la sección de fuente haz un clic en la lista desplegable del ícono de bordes y selecciona Todos los bordes.
  • Aplica Todos los bordes para cada grupo de celdas que seleccionas.

Para la hoja Vendedores

Haz un clic en la hoja Vendedores y creamos la siguiente tabla, tal como se muestra en la imagen:

Para la hoja Clientes

Haz un clic en la hoja Clientes y creamos la siguiente tabla:

Para la hoja Productos

Haz un clic en la hoja Productos y creamos la siguiente tabla:

Creamos las tres tablas con la finalidad de que cuando estemos en el diseño de la factura, podamos extraer los datos de estas tablas sólo ingresando el código que identifica a cada vendedor, cliente y producto.

TRABAJANDO CON FÓRMULAS

Insertar fecha

Para generar la fecha automáticamente en la factura y que ésta vaya cambiando con el transcurrir de los días, lo que debemos hacer es:

  • Clic en la celda donde insertaremos la fecha, en este caso la celda F5
  • Escribimos lo siguiente:
=HOY()

Para mostrar Datos del vendedor

Como lo habíamos dicho anteriormente, el código que identifica a cada vendedor es el que nos ayudará a rellenar los datos automáticamente en los demás campos del formato factura.

Para ello hacemos lo siguientes:

  • Clic en la celda donde se mostrará el nombre del vendedor, en este caso será la celda C20 y escribe lo siguiente:
=SI.ERROR(BUSCARV(D5;Vendedores!A:B;2;FALSO);"")

Lo que hará el código es que buscará en la celda D5 (celda donde se insertará el código del vendedor), para mostrar el dato específico que se encuentra en la hoja Vendedores dentro de la tabla A:B pero específicamente lo hará en la columna 2 de la tabla (columna B donde están los nombres).

Nota: el SI.ERROR lo escribimos en la fórmula con la finalidad de que, cuando el campo del nombre del vendedor esté vacío no nos muestre un mensaje de error con signo de admiración.

Para mostrar datos del cliente

Nombre del cliente

  • Clic en la celda donde se mostrará el nombre del cliente, en este caso la celda C7.
  • Ecribe la siguiente fórmula:
=SI.ERROR(BUSCARV(E7;Clientes!A:D;2;FALSO);" ")

Dirección

  • Clic en la celda donde se mostrará el nombre del cliente, en este caso la celda C8.
  • Ecribe la siguiente fórmula:
=SI.ERROR(BUSCARV(E7;Clientes!A:D;3;FALSO);" ")

Teléfono

  • Clic en la celda donde se mostrará el nombre del cliente, en este caso la celda E8.
  • Ecribe la siguiente fórmula:
=SI.ERROR(BUSCARV(E7;Clientes!A:D;4;FALSO);" ")

Para mostrar datos del producto

Producto

  • Clic en la celda donde se mostrará el nombre del cliente, en este caso la celda C11.
  • Ecribe la siguiente fórmula:
=SI.ERROR(BUSCARV(B11;Productos!A:C;2;FALSO);" ")

Precio

  • Clic en la celda donde se mostrará el nombre del cliente, en este caso la celda F11.
  • Ecribe la siguiente fórmula:
=SI.ERROR(BUSCARV(B11;Productos!A:C;3;FALSO);0)

Para realizar cálculos

Total

Para calcular el total por cada producto ingresado, haz un clic en la celda donde se realizará el cálculo, este caso la celda será G11 y escribe la siguiente fórmula:

=E11*F11

Sub-Total

Haz un clic en la celda donde se realizará el cálculo en este caso es la celda G18 y escribimos lo siguiente:

=SUMA(G11:G17)

IGV

Para este ejemplo el cálculo del IGV puede diferir según tu país, para este ejemplo se trabajó con el 18% que es el IGV que se aplica en Perú.

=G18*18%

Total

Para calcular el total escribimos la siguiente fórmula:

=SUMA(G18:G19)

Para descargar el material de apoyo que se usó en esta entrada para describir cada uno de los pasos, aquí te dejo el enlace: Descargar Factura.

Si te ha sido de mucha ayuda esta entrada, compártelo con tus amigos!!