Lista de asistencia en excel

Lista de asistencia en excel

Crear una lista de asistencia en Excel no es nada complicado, sólo debes contar con la lista detallada de tus alumnos o empleados y conocer algunas herramientas básicas de Excel para elaborar el formato de asistencia en excel.

Si ya tienes conocimiento básico sobre cómo crear tablas en Excel, esto será pan comido. En caso de no saber cómo crear tablas, aquí te enseño paso a paso.

Para este ejemplo tendremos como referencia la siguiente plantilla:

Lista de asistencia en excel

Esta plantilla está diseñado para 1 Bimestre y para 30 estudiantes.

Dentro de la hoja de cálculo de Excel, diseña la plantilla tal como se muestra en la imagen anterior.

Para que nuestro rango de datos tenga la apariencia de una tabla:

  • Selecciona todas las celdas
  • Ir a Inicio
  • Clic en la lista deplegable del ícono de bordes.
  • Selecciona Todos los bordes

Formatos que se aplicaron

  • El tamaño de las celdas a partir del comienzo de la numeración (1) hasta el final (Condición) son: alto de fila = 13
  • Para el tamaño de las celdas a partir de la primera fecha hasta Justificación tiene un ancho de columna: 1,86
  • En las fechas se consideró sólo fechas laborales; para aplicar esta condición seleccionamos todas las fechas que digitamos, ir a la pestaña Inicio, clic en la lista desplegable del ícono de Rellenar y selecciona series. En la ventana que aparece, en la sección de Unidad de tiempo marca la opción de Día laborable.
  • Para el resto de la tabla se aplicó Combinar y Centrar y Negrita.
  • Si quieres que el texto cambie de orientación y se vea hacia arriba, ir a la pestaña Inicio, clic en la lista desplegable del ícono de Orientación y selecciona Girar texto hacia arriba.

Para dar Formato a las letras A, F, T, J

  • Selecciona sólo las celdas donde colocarás las asistencias, para este ejemplo seleccionamos las celdas C6 hasta AP35
  • Ir a la pestaña Inicio
  • Clic en la lista desplegable del ícono de Formato Condicional.
  • Selecciona Nueva regla
  • En la ventana que aparece en la sección de: Seleccionar un tipo de regla, selecciona la opción: Aplicar formato únicamente a las celdas que contengan.
  • En la parte inferior de la misma ventana, específicamente en la sección: Dar formato únicamente a las celdas con, cambiaremos los valores.
  • Para la primera lista desplegable selecciona: Valor de la celda. En la segunda lista deblegable selecciona: Igual a
  • Y en el tercer campo escribir sólo la letra A.
  • Clic en el botón Formato
  • En la ventana que aparece selecciona la pestaña Relleno y elige el color de fondo que tendrá la letra A, para este ejemplo elegimos el color verde claro.
  • Finalmente clic en Aceptar.

Repite los mismo pasos para dar formato a las otras tres letras que faltan (T, F, J)

Para calcular el Total de Asistencias, Inasistencias, Tardanzas y Justificaciones

Para la columna de Asistencias

  • Clic en la primera celda de la columna de Asistencias, en este caso en la celda AQ6 y escribe la siguiente fórmula:
=SI(CONTAR.BLANCO(C6:AP6)=40;"";CONTAR.SI(C6:AP6;"A"))

En la columna de Inasistencias

  • Clic en la primera celda de la columna de Inasistencias, en este caso en la celda AR6 y escribe la siguiente fórmula:
=SI(CONTAR.BLANCO(C6:AP6)=40;"";CONTAR.SI(C6:AP6;"F"))

En la columna de Tardanzas

  • Clic en la primera celda de la columna de Tardanzas, en este caso en la celda AS6 y escribe la siguiente fórmula:
=SI(CONTAR.BLANCO(C6:AP6)=40;"";CONTAR.SI(C6:AP6;"T"))

Para la columna de Justificadas

  • Clic en la primera celda de la columna de Justificadas, en este caso en la celda AT6 y escribe la siguiente fórmula:
=SI(CONTAR.BLANCO(C6:AP6)=40;"";CONTAR.SI(C6:AP6;"J"))
  • Presiona la tecla Enter para aplicar la fórmula para cada caso.
  • Para copiar la misma fórmula para cada columna , haz un clic sobre la celda donde se aplicó la fórmula y en la esquina inferior de la celda aparecerá una cruz negra, haz un clic y arrastra sin soltar hasta la última celda de la columna.

Fórmula para mostrar Habilitado o Inhabilitado

Para este ejemplo se tomó como condición que cuando un alumno tenga mayor o igual a 5 Inasistencias, se mostrará que el alumno está Inhabilitado.

  • Haz un clic en la primera celda de la columna condición, para este ejemplo se comenzó en la celda AU6 y escribe la siguiente fórmula:
=SI(AR6="";"";SI(AR6>=5;"Inhabilitado";"Habilitado"))

Para dar color de fondo a las celdas (rojo y verde), sigue los mismos pasos que se hicieron anteriormento cuando se dio color de relleno a las letras A, F, T, J

Terminado de realizar todos los pasos tal como se describió, verificamos si todo funciona correctamente.

Ver imagen:

Lista de asistencia en excel

Aquí te dejo el link para descargar el formato de lista de asistencia en excel.

Si te gustó esta entrada compártelo con tus amigos para que ellos también puedan descargar esta plantilla de asistencias en Excel. 😉